summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-10 20:09:19 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-10 20:09:19 (GMT)
commit2a3349fc21653f9896074dac8295a4146eaceb70 (patch)
tree2a02c2e5ecc8f49f888fbe908e96ea635bdf061f /CMakeLists.txt
parenta48caa2db518172450da32c7e6830cafcf16d98f (diff)
downloadhdf5-2a3349fc21653f9896074dac8295a4146eaceb70.zip
hdf5-2a3349fc21653f9896074dac8295a4146eaceb70.tar.gz
hdf5-2a3349fc21653f9896074dac8295a4146eaceb70.tar.bz2
[svn-r19222] Move hl fortran ADD_SUBDIRECTORY to right after fortran ADD_SUBDIRECTORY. This fixes a problem with compiler generated files not including target module directory on some linux machines.
Corrected minor format/location of commands. Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b855419..0e44caa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -517,6 +517,12 @@ IF (HDF5_BUILD_FORTRAN)
IF(EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
ADD_SUBDIRECTORY (${HDF5_SOURCE_DIR}/fortran ${PROJECT_BINARY_DIR}/fortran)
ENDIF(EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
+ IF (HDF5_BUILD_HL_LIB)
+ IF(EXISTS "${HDF5_SOURCE_DIR}/hl/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/hl/fortran")
+ #-- Build the High Level Fortran source codes
+ ADD_SUBDIRECTORY (${HDF5_SOURCE_DIR}/hl/fortran ${HDF5_BINARY_DIR}/hl/fortran)
+ ENDIF(EXISTS "${HDF5_SOURCE_DIR}/hl/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/hl/fortran")
+ ENDIF (HDF5_BUILD_HL_LIB)
ELSE (HDF5_BUILD_FORTRAN)
SET (H5_FC_FUNC "H5_FC_FUNC(name,NAME) name ## _")
SET (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")