summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-28 21:29:01 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-28 21:29:01 (GMT)
commit9fc29cdd1c563aeab48952327e0910d83763236b (patch)
tree79e42983065499d89ded1501249a329d724747ac /CMakeLists.txt
parent9957d5f8e97ab00d7e487184db7c691cfcc13241 (diff)
downloadhdf5-9fc29cdd1c563aeab48952327e0910d83763236b.zip
hdf5-9fc29cdd1c563aeab48952327e0910d83763236b.tar.gz
hdf5-9fc29cdd1c563aeab48952327e0910d83763236b.tar.bz2
[svn-r18925] Updated install of fortran mod files
Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 5 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2efdfbe..30f9ece 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -569,14 +569,6 @@ INSTALL (
HDF5-config.cmake
)
-# The install rule below copies compiled module files to the install location
-# using a "code" rule. The code string should not be broken up, it must be on one line
-IF (HDF5_BUILD_FORTRAN)
- INSTALL ( CODE
- "EXECUTE_PROCESS (COMMAND \"${CMAKE_COMMAND}\" -E copy_directory \"${CMAKE_Fortran_MODULE_DIRECTORY}/\${BUILD_TYPE}\" \"${CMAKE_INSTALL_PREFIX}/fortran\")"
- )
-ENDIF (HDF5_BUILD_FORTRAN)
-
#-----------------------------------------------------------------------------
# Export all exported targets to the build tree for use by parent project
#-----------------------------------------------------------------------------
@@ -628,6 +620,11 @@ IF (HDF5_BUILD_FORTRAN)
DEPENDS libraries
GROUP Runtime
)
+ CPACK_ADD_COMPONENT (fortheaders
+ DISPLAY_NAME "HDF5 Fortran Headers"
+ DEPENDS fortlibraries
+ GROUP Development
+ )
ENDIF (HDF5_BUILD_FORTRAN)
IF (HDF5_BUILD_CPP_LIB)