summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-27 17:49:42 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-07-27 17:49:42 (GMT)
commit256fc4754b02dc2f684c792e48a913de15a2fc52 (patch)
treeb448c59e45ad926dd75376fa5dcd90f3f5574924 /CMakeLists.txt
parente1e10743cf342509b5e89b50fc43fb1d52a9c8d2 (diff)
downloadhdf5-256fc4754b02dc2f684c792e48a913de15a2fc52.zip
hdf5-256fc4754b02dc2f684c792e48a913de15a2fc52.tar.gz
hdf5-256fc4754b02dc2f684c792e48a913de15a2fc52.tar.bz2
Switch to CheckSymbolExists in CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 165ea9e..74c7095 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,8 +561,8 @@ if (HDF5_ENABLE_PARALLEL)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
# Used by Parallel Compression feature
- CHECK_FUNCTION_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
- CHECK_FUNCTION_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
+ CHECK_SYMBOL_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
+ CHECK_SYMBOL_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
if (NOT H5_HAVE_MPI_Mprobe OR NOT H5_HAVE_MPI_Imrecv)
message (WARNING "The MPI_Mprobe and/or MPI_Imrecv functions could not be located.
Parallel writes of filtered data will be disabled.")