summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-08-17 19:48:43 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-08-17 19:48:43 (GMT)
commitae7da889ece8ea6cfe3207f146ee991951b5ce66 (patch)
tree90a56d75e0a3477b059ee12545ba9702977e837e /CMakeLists.txt
parent105a05cb9072d21b4158eb9743990b07623097a7 (diff)
downloadhdf5-ae7da889ece8ea6cfe3207f146ee991951b5ce66.zip
hdf5-ae7da889ece8ea6cfe3207f146ee991951b5ce66.tar.gz
hdf5-ae7da889ece8ea6cfe3207f146ee991951b5ce66.tar.bz2
HDFFV-10552 Add missing HDF5_USE_110[2]_API_DEFAULT option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cdb31c..b76f332 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -620,6 +620,26 @@ if (HDF5_USE_18_API_DEFAULT)
endif ()
#-----------------------------------------------------------------------------
+# Option to use 1.10.x API
+#-----------------------------------------------------------------------------
+option (HDF5_USE_110_API_DEFAULT "Use the HDF5 1.10.x API by default" OFF)
+set (H5_USE_110_API_DEFAULT 0)
+if (HDF5_USE_110_API_DEFAULT)
+ set (H5_USE_110_API_DEFAULT 1)
+ set (DEFAULT_API_VERSION "v110")
+endif ()
+
+#-----------------------------------------------------------------------------
+# Option to use 1.12.x API
+#-----------------------------------------------------------------------------
+option (HDF5_USE_112_API_DEFAULT "Use the HDF5 1.12.x API by default" ON)
+set (H5_USE_112_API_DEFAULT 0)
+if (HDF5_USE_112_API_DEFAULT)
+ set (H5_USE_112_API_DEFAULT 1)
+ set (DEFAULT_API_VERSION "v112")
+endif ()
+
+#-----------------------------------------------------------------------------
# Include user macros
#-----------------------------------------------------------------------------
include (UserMacros.cmake)