summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-08-13 17:57:19 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-08-13 17:57:19 (GMT)
commitaeb145428f5e6bc51742fff031b0cf8cf6fbefbb (patch)
treed704d20286625755726d0800192e78ef60696226 /CMakeLists.txt
parent60b62b10f1acbee14f6ec90d85922b8fefb0eeb4 (diff)
parentd95745235a468b17f697843adb3d0e54bd919893 (diff)
downloadhdf5-aeb145428f5e6bc51742fff031b0cf8cf6fbefbb.zip
hdf5-aeb145428f5e6bc51742fff031b0cf8cf6fbefbb.tar.gz
hdf5-aeb145428f5e6bc51742fff031b0cf8cf6fbefbb.tar.bz2
Merge pull request #1860 in HDFFV/hdf5 from ~DEROBINS/hdf5_der:map_api_merge to develop
* commit 'd95745235a468b17f697843adb3d0e54bd919893': Updated h5trav.c to emit output that doesn't require ddl changes for map support. Fixed Map API CMake option Renamed H5Mdelete_key to H5Mdelete and H5Mset to H5Mput. Added the map (H5M) API
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 374e15e..eb22c7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -705,6 +705,7 @@ if (NOT HDF5_EXTERNALLY_CONFIGURED)
endif ()
endif ()
endif ()
+
#-----------------------------------------------------------------------------
# Option to use threadsafe
#-----------------------------------------------------------------------------
@@ -759,6 +760,14 @@ if (HDF5_ENABLE_THREADSAFE)
endif ()
#-----------------------------------------------------------------------------
+# Option to build the map API
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_MAP_API "Build the map API" OFF)
+if (HDF5_ENABLE_MAP_API)
+ set (H5_HAVE_MAP_API 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Add the HDF5 Library Target to the build
#-----------------------------------------------------------------------------
add_subdirectory (src)