summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-10-19 22:26:13 (GMT)
committerGitHub <noreply@github.com>2023-10-19 22:26:13 (GMT)
commitce864f6040c65df7909931c06ac72c18a8ce9ff7 (patch)
tree2c2b2f79209b5871cf8b5280ac64ac4c1e21e7b9 /CMakeLists.txt
parent1a898e792ee629afa20962a136dbb239f9c8e774 (diff)
downloadhdf5-ce864f6040c65df7909931c06ac72c18a8ce9ff7.zip
hdf5-ce864f6040c65df7909931c06ac72c18a8ce9ff7.tar.gz
hdf5-ce864f6040c65df7909931c06ac72c18a8ce9ff7.tar.bz2
Some corrections and fix for plugins (#3713)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d96cc56..09fee70 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -413,6 +413,13 @@ set (HDF5_PACKAGE_URL "http://www.hdfgroup.org")
set (HDF5_PACKAGE_BUGREPORT "help@hdfgroup.org")
#-----------------------------------------------------------------------------
+# Set variables needed for installation
+#-----------------------------------------------------------------------------
+set (HDF5_VERSION_STRING ${HDF5_PACKAGE_VERSION})
+set (HDF5_VERSION_MAJOR ${HDF5_PACKAGE_VERSION_MAJOR})
+set (HDF5_VERSION_MINOR ${HDF5_PACKAGE_VERSION_MINOR})
+
+#-----------------------------------------------------------------------------
# Include some macros for reusable code
#-----------------------------------------------------------------------------
include (${HDF_RESOURCES_DIR}/HDFMacros.cmake)