summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSean McBride <sean@rogue-research.com>2021-03-10 17:51:45 (GMT)
committerGitHub <noreply@github.com>2021-03-10 17:51:45 (GMT)
commit20c452fe5c0955a81ae1222d846632f1525f08f4 (patch)
tree79ebdf43a51b3283625742e02614f1c3f15fc3b6 /CMakeLists.txt
parentc41a1cb2094ae0cc5fb40671181ce4e9f73ba9dc (diff)
downloadhdf5-20c452fe5c0955a81ae1222d846632f1525f08f4.zip
hdf5-20c452fe5c0955a81ae1222d846632f1525f08f4.tar.gz
hdf5-20c452fe5c0955a81ae1222d846632f1525f08f4.tar.bz2
Removed checks/workarounds for pre-C++89 compatibility (#449)
After 30+ years, just assume that the following exist: - extension-less includes - namespaces - std:: - static_cast - bool
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 04e34f1..9809339 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1107,9 +1107,6 @@ if (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++")
include (${HDF_RESOURCES_EXT_DIR}/HDFUseCXX.cmake)
include (${HDF_RESOURCES_DIR}/HDFCXXCompilerFlags.cmake)
- if (CMAKE_NO_STD_NAMESPACE)
- set (H5_NO_STD 1)
- endif ()
add_subdirectory (c++)
if (HDF5_BUILD_HL_LIB)
if (EXISTS "${HDF5_SOURCE_DIR}/hl/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/hl/c++")