summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2021-12-02 05:33:25 (GMT)
committerGitHub <noreply@github.com>2021-12-02 05:33:25 (GMT)
commit2b4c2d9c7163274ad6008e701413edfd10f88b3b (patch)
treefa35b96f7b5b5b41b8df2dd7795f05889e6043c0 /CMakeLists.txt
parente048f659abb43b1c7747a13318ea42b2d33cd4d1 (diff)
downloadhdf5-2b4c2d9c7163274ad6008e701413edfd10f88b3b.zip
hdf5-2b4c2d9c7163274ad6008e701413edfd10f88b3b.tar.gz
hdf5-2b4c2d9c7163274ad6008e701413edfd10f88b3b.tar.bz2
Add missing files for enabling doxygen and run bin/reconfigure. (#1246)
* Add missing files for enabling doxygen and run bin/reconfigure. * Make default to build high-level tools the same as default for high-level library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index db94b1d..43c6efc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -483,20 +483,6 @@ endif ()
# endif ()
#-----------------------------------------------------------------------------
-# Option to build documentation
-#-----------------------------------------------------------------------------
-option (HDF5_BUILD_DOC "Build documentation" OFF)
-if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOXYGEN_DIR}")
-# check if Doxygen is installed
- find_package(Doxygen)
- if (DOXYGEN_FOUND)
- message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
- else ()
- message(STATUS "Doxygen needs to be installed to generate the doxygen documentation")
- endif ()
-endif ()
-
-#-----------------------------------------------------------------------------
# Option to indicate using a memory checker
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_USING_MEMCHECKER "Indicate that a memory checker is used" OFF)