summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-12-20 19:42:41 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-12-20 19:42:41 (GMT)
commitc7bf2222f1cbe97b9fc1e29e21717632874b63b9 (patch)
tree40ddf4132083e9cbc1036bdb429cb9d422d07709 /CMakeLists.txt
parent1dbec5a7c30115f98f7ff1785772fd30b1a4f7e9 (diff)
downloadhdf5-c7bf2222f1cbe97b9fc1e29e21717632874b63b9.zip
hdf5-c7bf2222f1cbe97b9fc1e29e21717632874b63b9.tar.gz
hdf5-c7bf2222f1cbe97b9fc1e29e21717632874b63b9.tar.bz2
Reworked MPI includes to be used as default with parallel
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da2382b..759530b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -542,6 +542,7 @@ if (HDF5_ENABLE_PARALLEL)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
+ INCLUDE_DIRECTORIES (${MPI_C_INCLUDE_DIRS})
else ()
message (STATUS "Parallel libraries not found")
endif ()