summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2012-06-01 17:07:58 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2012-06-01 17:07:58 (GMT)
commitd77d0103b3ca63328ecf2a4f6576cdc58bad480b (patch)
treee1209adb76bba2cee9426d42563e5d3fc88a4cb2 /CMakeLists.txt
parent7d93246d6fafb70130c2e72a82d34db538b016d3 (diff)
downloadhdf5-d77d0103b3ca63328ecf2a4f6576cdc58bad480b.zip
hdf5-d77d0103b3ca63328ecf2a4f6576cdc58bad480b.tar.gz
hdf5-d77d0103b3ca63328ecf2a4f6576cdc58bad480b.tar.bz2
[svn-r22425] CMake generated libsettings needed DEFAULT_API_VERSION set
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd50c99..edd7b62 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -482,6 +482,7 @@ IF (H5_HAVE_PARALLEL)
ENDIF (MPI_C_LINK_FLAGS)
ENDIF (H5_HAVE_PARALLEL)
+SET (DEFAULT_API_VERSION "v18")
#-----------------------------------------------------------------------------
# Option to use 1.6.x API
#-----------------------------------------------------------------------------
@@ -489,6 +490,7 @@ OPTION (HDF5_USE_16_API_DEFAULT "Use the HDF5 1.6.x API by default" OFF)
SET (H5_USE_16_API_DEFAULT 0)
IF (HDF5_USE_16_API_DEFAULT)
SET (H5_USE_16_API_DEFAULT 1)
+ SET (DEFAULT_API_VERSION "v16")
ENDIF (HDF5_USE_16_API_DEFAULT)
#-----------------------------------------------------------------------------