summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJerome Soumagne <jsoumagne@hdfgroup.org>2013-12-10 17:05:44 (GMT)
committerJerome Soumagne <jsoumagne@hdfgroup.org>2013-12-10 17:05:44 (GMT)
commit32650995eb862992401310e14168c23dfa8043c2 (patch)
treed5068b3a4860722236cf7839afe68c7ecf7dcbe4 /CMakeLists.txt
parentcb7a1cb7dddb8035fcb67bd6ca5489c7cd080157 (diff)
downloadhdf5-32650995eb862992401310e14168c23dfa8043c2.zip
hdf5-32650995eb862992401310e14168c23dfa8043c2.tar.gz
hdf5-32650995eb862992401310e14168c23dfa8043c2.tar.bz2
[svn-r24523] Add FindPythonNumPy.cmake to properly get numpy headers
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 425aa3a..299c6fc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -711,6 +711,12 @@ IF (HDF5_ENABLE_PARALLEL)
ELSE (PYTHONLIBS_FOUND)
MESSAGE (FATAL_ERROR "Could not find Python Libraries, please check PYTHON_INCLUDE_DIR.")
ENDIF (PYTHONLIBS_FOUND)
+ FIND_PACKAGE(PythonNumPy REQUIRED)
+ IF (PYTHON_NUMPY_FOUND)
+ INCLUDE_DIRECTORIES (${PYTHON_NUMPY_INCLUDE_DIR})
+ ELSE (PYTHON_NUMPY_FOUND)
+ MESSAGE (FATAL_ERROR "Could not find NumPy headers, please check PYTHON_EXECUTABLE.")
+ ENDIF (PYTHON_NUMPY_FOUND)
ENDIF (HDF5_ENABLE_PYTHON)
ENDIF (HDF5_ENABLE_EFF)
ENDIF (HDF5_ENABLE_PARALLEL)