summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-27 17:49:42 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-08-02 14:46:45 (GMT)
commitd4298589fe3260be28a7a2112b48796a217a039a (patch)
tree84372e91a364d7faca1b7e48b1a4fea4b9f88e48 /CMakeLists.txt
parent0623b06b15a6b33d05393f481994ebfb1a22b48c (diff)
downloadhdf5-d4298589fe3260be28a7a2112b48796a217a039a.zip
hdf5-d4298589fe3260be28a7a2112b48796a217a039a.tar.gz
hdf5-d4298589fe3260be28a7a2112b48796a217a039a.tar.bz2
Switch to CheckSymbolExists in CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2cc314..6a7ac91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,8 +561,8 @@ if (HDF5_ENABLE_PARALLEL)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
# Used by Parallel Compression feature
- CHECK_FUNCTION_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
- CHECK_FUNCTION_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
+ CHECK_SYMBOL_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
+ CHECK_SYMBOL_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
if (NOT H5_HAVE_MPI_Mprobe OR NOT H5_HAVE_MPI_Imrecv)
message (WARNING "The MPI_Mprobe and/or MPI_Imrecv functions could not be located.
Parallel writes of filtered data will be disabled.")