summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2014-09-03 17:12:52 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2014-09-03 17:12:52 (GMT)
commitc23f3a7ea577b66f103ab06e9310e819c13f5401 (patch)
tree5fd6bbaf00a3973ea0d0e591d9b6256b687c91a2 /CMakeLists.txt
parent2154d1c6f1b791a2ba9125a48a098fd4da42f01f (diff)
downloadhdf5-c23f3a7ea577b66f103ab06e9310e819c13f5401.zip
hdf5-c23f3a7ea577b66f103ab06e9310e819c13f5401.tar.gz
hdf5-c23f3a7ea577b66f103ab06e9310e819c13f5401.tar.bz2
[svn-r25569] Added option to build tools static when building shared libraries. This will prevent 'dll' being appended to the tool name on windows. See HDFFV-8292.
Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6877b6a..a584e89 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -283,8 +283,8 @@ if (BUILD_SHARED_LIBS)
else (BUILD_SHARED_LIBS)
set (H5_BUILT_AS_STATIC_LIB 1)
set (H5_ENABLE_STATIC_LIB YES)
- set (CMAKE_POSITION_INDEPENDENT_CODE ON)
endif (BUILD_SHARED_LIBS)
+set (CMAKE_POSITION_INDEPENDENT_CODE ON)
#-----------------------------------------------------------------------------
# Option to Build Static executables