summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-10-13 21:15:31 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-10-13 21:15:31 (GMT)
commit2abe5da201ec47cc95f9d666cd32ff4efb5aafb6 (patch)
tree312b7bac03b6f626f5d7341cd7c02bd323d7fdbc /CMakeLists.txt
parent2c9b575d389760de5c09ab0acf43c4e990ef3fe4 (diff)
downloadhdf5-2abe5da201ec47cc95f9d666cd32ff4efb5aafb6.zip
hdf5-2abe5da201ec47cc95f9d666cd32ff4efb5aafb6.tar.gz
hdf5-2abe5da201ec47cc95f9d666cd32ff4efb5aafb6.tar.bz2
[svn-r28059] Make UNSUPPORTED option combinations fail configure - matches autotools behaviour.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0eaba05..88e58e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -557,24 +557,21 @@ if (WIN32)
endif (HDF5_ENABLE_PARALLEL)
if (HDF5_BUILD_FORTRAN)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** Fortran and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building Fortran library **** ")
+ message (FATAL_ERROR " **** Fortran and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported Fortran and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_FORTRAN)
if (HDF5_BUILD_CPP_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** C++ and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building C++ library **** ")
+ message (FATAL_ERROR " **** C++ and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_CPP_LIB)
if (HDF5_BUILD_HL_LIB)
if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** HL and thread-safety options are not supported **** ")
- message (STATUS " **** thread-safety option will not be used building HL library **** ")
+ message (FATAL_ERROR " **** HL and thread-safety options are not supported **** ")
else (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)