summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-12-07 14:56:04 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-12-07 14:56:04 (GMT)
commit6eab04894e88f7dcc0e684271328efc409a98662 (patch)
treeaa5bf402b01bb378be17a48b15e61291ad4927fe /CMakeLists.txt
parentb391e160b0429e7758efbb662ba1f89b28b4fe99 (diff)
downloadhdf5-6eab04894e88f7dcc0e684271328efc409a98662.zip
hdf5-6eab04894e88f7dcc0e684271328efc409a98662.tar.gz
hdf5-6eab04894e88f7dcc0e684271328efc409a98662.tar.bz2
HDFFV-10223 Shared libraries fail test on OSX with fortran enabled with cmake
This is now fixed via the HDFFV-10325 fix.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2640b1..e22ac2e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -849,21 +849,8 @@ set (H5_FC_FUNC "H5_FC_FUNC(name,NAME) name ## _")
set (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")
if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
option (HDF5_BUILD_FORTRAN "Build FORTRAN support" OFF)
- option (SKIP_HDF5_FORTRAN_SHARED "Do not build the fortran shared libraries" OFF)
if (HDF5_BUILD_FORTRAN)
- if (BUILD_SHARED_LIBS AND APPLE)
- # Tell cmake to do the right thing with COMMON symbols, this fixes
- # corrupt values with COMMON and EQUIVALENCE when building shared
- # Fortran libraries on OSX with gnu and Intel compilers (HDFFV-2772).
- # *** NOTE: Fix does not work with Cmake. ***
- # set (HDF5_LINKER_FLAGS "-Wl,-commons,use_dylibs")
- if (NOT ALLOW_UNSUPPORTED)
- message (STATUS " **** Shared FORTRAN libraries are unsupported **** ")
- set (SKIP_HDF5_FORTRAN_SHARED ON)
- else ()
- message (STATUS " **** Allowing unsupported Fortran shared libraries **** ")
- endif ()
- endif ()
+
option (HDF5_ENABLE_F2003 "Enable FORTRAN 2003 Standard" ON)
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)