summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2019-01-07 15:49:52 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2019-01-07 15:49:52 (GMT)
commitb4828e7feb8fd11514683c6eef8809356751760a (patch)
tree0364fb7dceb3573fe95d8512669f027595c2fa83 /CMakeLists.txt
parent390a3f67282e64752a14e2c1ed13545fde8712d1 (diff)
parent7bf6d847ae36940f1b1147820356795c7764dbeb (diff)
downloadhdf5-b4828e7feb8fd11514683c6eef8809356751760a.zip
hdf5-b4828e7feb8fd11514683c6eef8809356751760a.tar.gz
hdf5-b4828e7feb8fd11514683c6eef8809356751760a.tar.bz2
Merge branch 'develop' of https://bitbucket.hdfgroup.org/scm/hdffv/hdf5 into develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2fb000..a16cb08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -756,6 +756,13 @@ if (BUILD_TESTING)
mark_as_advanced (HDF5_TEST_FHEAP_VFD)
endif ()
+ option (HDF5_TEST_VOL "Execute tests with different VOL connectors" OFF)
+ mark_as_advanced (HDF5_TEST_VOL)
+ if (HDF5_TEST_VOL)
+ option (HDF5_TEST_FHEAP_VOL "Execute fheap test with different VOL connectors" ON)
+ mark_as_advanced (HDF5_TEST_FHEAP_VOL)
+ endif ()
+
option (HDF_TEST_EXPRESS "Control testing framework (0-3)" "0")
mark_as_advanced (HDF_TEST_EXPRESS)