summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-26 17:50:26 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-07-26 17:50:26 (GMT)
commite1e10743cf342509b5e89b50fc43fb1d52a9c8d2 (patch)
tree4801126aeea3b4ac5960dfa41169a5fe0fe4e6c3 /CMakeLists.txt
parent5550fb330a00ef75b6ab6daa6d8dae8bcf832185 (diff)
downloadhdf5-e1e10743cf342509b5e89b50fc43fb1d52a9c8d2.zip
hdf5-e1e10743cf342509b5e89b50fc43fb1d52a9c8d2.tar.gz
hdf5-e1e10743cf342509b5e89b50fc43fb1d52a9c8d2.tar.bz2
Add configure check for MPI_Mprobe and MPI_Imrecv functions
Add line to libhdf5settings file for status of Parallel writes to filtered datasets status Surround Parallel Compression code in MPI_VERSION >= 3 checks Add disabled message for Parallel Compression built w/ MPI-2 Modify Parallel Compression tests to only run the parallel filtered read tests when parallel filtered writes are disabled Update big I/O code to handle being built with MPI-2 Add checks to CMakeLists.txt for MPI_Mprobe and MPI_Imrecv
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0640b9..165ea9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -559,6 +559,14 @@ if (HDF5_ENABLE_PARALLEL)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
+
+ # Used by Parallel Compression feature
+ CHECK_FUNCTION_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
+ CHECK_FUNCTION_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
+ if (NOT H5_HAVE_MPI_Mprobe OR NOT H5_HAVE_MPI_Imrecv)
+ message (WARNING "The MPI_Mprobe and/or MPI_Imrecv functions could not be located.
+ Parallel writes of filtered data will be disabled.")
+ endif ()
else ()
message (STATUS "Parallel libraries not found")
endif ()