summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2014-07-07 18:22:48 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2014-07-07 18:22:48 (GMT)
commit06ef71a37fab21fac487593789cd41e2c5d03007 (patch)
treea8ef3582573725f38879ab8a05de4db386bcf733 /CMakeLists.txt
parent5ad9bfb32229ce1a1a42ed9e5574dcba23ba1a2c (diff)
downloadhdf5-06ef71a37fab21fac487593789cd41e2c5d03007.zip
hdf5-06ef71a37fab21fac487593789cd41e2c5d03007.tar.gz
hdf5-06ef71a37fab21fac487593789cd41e2c5d03007.tar.bz2
[svn-r25397] - remove configure checks for MPI_File_get_size and Big
MPI_File_set_size as they are supported by most MPI implementations. - fix bug in t_mpi.c (HDFFV-8856)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd0ae5d..9ee21de 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -643,8 +643,6 @@ if (HDF5_ENABLE_PARALLEL)
# MPI checks, only do these if MPI_C_FOUND is true, otherwise they always fail
# and once set, they are cached as false and not regenerated
set (CMAKE_REQUIRED_LIBRARIES "${MPI_C_LIBRARIES}" )
- CHECK_FUNCTION_EXISTS (MPI_File_get_size H5_HAVE_MPI_GET_SIZE)
- set (H5_MPI_FILE_SET_SIZE_BIG 1)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_C_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)