summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-10-27 15:48:57 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-10-27 15:48:57 (GMT)
commit1f27dc4d04828a62c74942ee53ff9dec21aaa6d9 (patch)
tree37988760487940b1e5fed6487b07c91913109001 /CMakeLists.txt
parent1fd8a32c91aa52e4c978187326d45498d7209a68 (diff)
downloadhdf5-1f27dc4d04828a62c74942ee53ff9dec21aaa6d9.zip
hdf5-1f27dc4d04828a62c74942ee53ff9dec21aaa6d9.tar.gz
hdf5-1f27dc4d04828a62c74942ee53ff9dec21aaa6d9.tar.bz2
[svn-r19674] MPI_ checks were failing due to wrong #include of mpi.h in cmake setup
From Community
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10503ac..e4ae935 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,8 +398,7 @@ IF (HDF5_ENABLE_PARALLEL)
SET (H5_HAVE_PARALLEL 1)
# MPI checks, only do these if MPI_FOUND is true, otherwise they always fail
# and once set, they are cached as false and not regenerated
- SET (CMAKE_REQUIRED_INCLUDES "${MPI_INCLUDE_PATH}/mpi.h" )
- SET (CMAKE_REQUIRED_LIBRARIES "${MPI_LIBRARY}" )
+ SET (CMAKE_REQUIRED_LIBRARIES "${MPI_LIBRARY};${MPI_EXTRA_LIBRARY}" )
CHECK_FUNCTION_EXISTS (MPI_File_get_size H5_HAVE_MPI_GET_SIZE)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_INCLUDE_PATH}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)