summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-09-24 19:14:44 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-09-24 19:14:44 (GMT)
commit2c99d728f05b6f32c6299a40e88cfe351a06c639 (patch)
tree2baecb1c93d3a97d52c0af19fd3db4971c2f8c98 /CMakeLists.txt
parent5430c32938f9c40df63254940ef18758c94defe1 (diff)
downloadhdf5-2c99d728f05b6f32c6299a40e88cfe351a06c639.zip
hdf5-2c99d728f05b6f32c6299a40e88cfe351a06c639.tar.gz
hdf5-2c99d728f05b6f32c6299a40e88cfe351a06c639.tar.bz2
[svn-r27874] Add ability to extend the cmake path for searching for libraries/programs.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96d5772..1035142 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -212,6 +212,10 @@ if (NOT HDF5_INSTALL_DATA_DIR)
endif (NOT WIN32)
endif (NOT HDF5_INSTALL_DATA_DIR)
+if(DEFINED ADDITIONAL_CMAKE_PREFIX_PATH AND EXISTS "${ADDITIONAL_CMAKE_PREFIX_PATH}")
+ set (CMAKE_PREFIX_PATH ${ADDITIONAL_CMAKE_PREFIX_PATH} ${CMAKE_PREFIX_PATH})
+endif(DEFINED ADDITIONAL_CMAKE_PREFIX_PATH AND EXISTS "${ADDITIONAL_CMAKE_PREFIX_PATH}")
+
#-----------------------------------------------------------------------------
# parse the full version number from H5public.h and include in H5_VERS_INFO
#-----------------------------------------------------------------------------