summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-21 16:53:40 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-21 16:53:40 (GMT)
commit6813b25007280afa9b8bec13c19c134029acd26c (patch)
treef2462aa00644888fa0798b11125bf8be29726339 /CMakeLists.txt
parentc88f2abea5c4295cd20564fede8b3010933c0e6f (diff)
downloadhdf5-6813b25007280afa9b8bec13c19c134029acd26c.zip
hdf5-6813b25007280afa9b8bec13c19c134029acd26c.tar.gz
hdf5-6813b25007280afa9b8bec13c19c134029acd26c.tar.bz2
[svn-r26866] Removed the default REAL and DOUBLE PRECESION dependency.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a4135f4..97b4463 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -886,16 +886,6 @@ if (EXISTS "${HDF5_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/tools
endif (EXISTS "${HDF5_SOURCE_DIR}/tools" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/tools")
#-----------------------------------------------------------------------------
-# Check if Fortran's default real is double precision. If it is and HL is
-# being built then configure should fail due to bug HDFFV-889.
-#-----------------------------------------------------------------------------
- if (HDF5_BUILD_FORTRAN AND HDF5_BUILD_HL_LIB )
- if (NOT FORTRAN_DEFAULT_REAL_NOT_DOUBLE)
- message (FATAL_ERROR " **** Fortran high-level routines are not supported when the default REAL is DOUBLE PRECISION, use HDF5_BUILD_HL_LIB:BOOL=OFF **** ")
- endif (NOT FORTRAN_DEFAULT_REAL_NOT_DOUBLE)
- endif (HDF5_BUILD_FORTRAN AND HDF5_BUILD_HL_LIB )
-
-#-----------------------------------------------------------------------------
# Generate the H5pubconf.h file containing user settings needed by compilation
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)