summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-12-20 19:10:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-12-20 19:10:34 (GMT)
commit925f3c9b54368005da0129d5928142f04f53ef57 (patch)
tree9e9471386dcd64ce1d28dd809fdd03f666254621 /CMakeLists.txt
parent94b8a212bfba2ad7a7740c8a22e0e5d96d05e4ec (diff)
downloadhdf5-925f3c9b54368005da0129d5928142f04f53ef57.zip
hdf5-925f3c9b54368005da0129d5928142f04f53ef57.tar.gz
hdf5-925f3c9b54368005da0129d5928142f04f53ef57.tar.bz2
Because of MPI requirements in library ALWAYS add include path
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e22ac2e..6165b35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -631,6 +631,7 @@ if (HDF5_ENABLE_PARALLEL)
# Used by Fortran + MPI
CHECK_SYMBOL_EXISTS (MPI_Comm_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Comm)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
+ INCLUDE_DIRECTORIES (${MPI_C_INCLUDE_DIRS})
else ()
message (STATUS "Parallel libraries not found")
endif ()