summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-02-17 18:43:47 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-02-17 18:43:47 (GMT)
commitc37ecd5bba292e2b594547e0eeb6a385d20194b0 (patch)
tree8ab7f771dd5b60dd5c87de6659d18204f1635223 /CMakeLists.txt
parentc4a208819db987cdc93d58a38b724092388c2244 (diff)
downloadhdf5-c37ecd5bba292e2b594547e0eeb6a385d20194b0.zip
hdf5-c37ecd5bba292e2b594547e0eeb6a385d20194b0.tar.gz
hdf5-c37ecd5bba292e2b594547e0eeb6a385d20194b0.tar.bz2
Add MPI_Fortran variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4b5e09..9016f29 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -877,6 +877,15 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
endif ()
endif ()
+ # Parallel IO usage requires MPI to be Linked and Included
+ if (H5_HAVE_PARALLEL)
+ set (LINK_Fortran_LIBS ${LINK_LIBS} ${MPI_Fortran_LIBRARIES})
+ set (LINK_Fortran_SHARED_LIBS ${LINK_SHARED_LIBS} ${MPI_Fortran_LIBRARIES})
+ if (MPI_Fortran_LINK_FLAGS)
+ set (CMAKE_Fortran_EXE_LINKER_FLAGS "${MPI_Fortran_LINK_FLAGS} ${CMAKE_EXE_LINKER_FLAGS}")
+ endif ()
+ endif ()
+
# -----------------------------------------------------------------------
# wrapper script variables
#