summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-02-01 22:01:22 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-02-01 22:01:22 (GMT)
commit2d4f58adf0bd1774485686cea5d7c7c0ba8c2091 (patch)
tree03d612447cbf33cce05abf124aeb0fbf0129a0cb /CMakeLists.txt
parentf90e5bdc62bd73ea6af977f4d5d3d40a36d008f6 (diff)
parent055208b71c573be3d4b1047b840d4d8b255bc25e (diff)
downloadhdf5-2d4f58adf0bd1774485686cea5d7c7c0ba8c2091.zip
hdf5-2d4f58adf0bd1774485686cea5d7c7c0ba8c2091.tar.gz
hdf5-2d4f58adf0bd1774485686cea5d7c7c0ba8c2091.tar.bz2
Merge pull request #1515 in HDFFV/hdf5 from ~DEROBINS/hdf5_der:pread_vfd_squash to develop
* commit '055208b71c573be3d4b1047b840d4d8b255bc25e': Minor tweak to CMake preadwrite entry. Updated sec2, log, and core VFDs to use pread/pwrite when available (can be controlled via a configure/CMake option)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a16cb08..85f701e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -482,6 +482,15 @@ if (HDF5_MEMORY_ALLOC_SANITY_CHECK)
endif ()
#-----------------------------------------------------------------------------
+# Option to enable/disable using pread/pwrite for VFDs
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_PREADWRITE "Use pread/pwrite in sec2/log/core VFDs in place of read/write (when available)" ON)
+mark_as_advanced (HDF5_ENABLE_PREADWRITE)
+if (HDF5_ENABLE_PREADWRITE AND H5_HAVE_PREAD AND H5_HAVE_PWRITE)
+ set (H5_HAVE_PREADWRITE 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Option to use deprecated public API symbols
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_DEPRECATED_SYMBOLS "Enable deprecated public API symbols" ON)