summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-01-27 14:59:04 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-01-27 14:59:04 (GMT)
commit0a15d73625e223771a4292cfabfeb774fd9b0f11 (patch)
tree3813c5dd4e4903863e68426f9e0ada5f8a7c89c6 /CMakeLists.txt
parentc439bb5d29c2e661d929f43504b3b762284bd753 (diff)
downloadhdf5-0a15d73625e223771a4292cfabfeb774fd9b0f11.zip
hdf5-0a15d73625e223771a4292cfabfeb774fd9b0f11.tar.gz
hdf5-0a15d73625e223771a4292cfabfeb774fd9b0f11.tar.bz2
[svn-r20013] Change use of variable to allow a SITE name to be defined, to using it to extend the build name used in reporting to CDash
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7812487..cda2dad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,9 +69,11 @@ PROJECT (HDF5 C CXX)
# # Add the sub project
# ADD_SUBDIRECTORY(Utilities/hdf5-1.8)
#-----------------------------------------------------------------------------
-IF (SITE_NAME_VAR)
- SET (SITE ${SITE_NAME_VAR})
-ENDIF (SITE_NAME_VAR)
+IF (BUILD_SHARED_LIBS)
+ SET (BUILD_NAME_EXT "SHARED")
+ELSE (BUILD_SHARED_LIBS)
+ SET (BUILD_NAME_EXT "STATIC")
+ENDIF (BUILD_SHARED_LIBS)
#-----------------------------------------------------------------------------
# Set the core names of all the libraries