summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-08-19 15:11:10 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-08-19 15:11:10 (GMT)
commit13426d47feb8b5d417c83a1b38de08fff66cf1e0 (patch)
treeb6eb4329c68168b9d36dd6dd001619175e5b1faf /CMakeLists.txt
parent5213c69fd59f34733dcbd5285ddc00d2b2b9e7a5 (diff)
downloadhdf5-13426d47feb8b5d417c83a1b38de08fff66cf1e0.zip
hdf5-13426d47feb8b5d417c83a1b38de08fff66cf1e0.tar.gz
hdf5-13426d47feb8b5d417c83a1b38de08fff66cf1e0.tar.bz2
[svn-r21263] Add F2003 support to CMake builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d46aeee..5e5f8bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -700,6 +700,7 @@ SET (H5_FC_FUNC_ "H5_FC_FUNC_(name,NAME) name ## _")
IF (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/fortran")
OPTION (HDF5_BUILD_FORTRAN "Build FORTRAN support" OFF)
IF (HDF5_BUILD_FORTRAN)
+ OPTION (HDF5_ENABLE_F2003 "Enable FORTRAN 2003 Standard" OFF)
INCLUDE (${HDF5_RESOURCES_DIR}/HDF5UseFortran.cmake)
ADD_SUBDIRECTORY (${HDF5_SOURCE_DIR}/fortran ${PROJECT_BINARY_DIR}/fortran)
IF (HDF5_BUILD_HL_LIB)