summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-10-06 19:25:13 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-10-06 19:25:13 (GMT)
commit1f115749c4e53c2cd83744fd4008897b3cb96e77 (patch)
treee2f323086d2be9be54bc6fd7fedaf34309ef1bee /CMakeLists.txt
parent07d7090609fca942ef6b5f713ecf477b85bbdc34 (diff)
downloadhdf5-1f115749c4e53c2cd83744fd4008897b3cb96e77.zip
hdf5-1f115749c4e53c2cd83744fd4008897b3cb96e77.tar.gz
hdf5-1f115749c4e53c2cd83744fd4008897b3cb96e77.tar.bz2
[svn-r21481] Add option to enable windows stdio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d7209ea..fb1c0c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -250,6 +250,16 @@ IF (WIN32 AND NOT CYGWIN)
ENDIF (WIN32 AND NOT CYGWIN)
#-----------------------------------------------------------------------------
+# Option to enable use of stdio instead of posix io
+#-----------------------------------------------------------------------------
+IF (WIN32)
+ OPTION (HDF5_ENABLE_WINDOWS_STDIO "Enable use of stdio instead of posix io" OFF)
+ IF (HDF5_ENABLE_WINDOWS_STDIO)
+ SET (H5_WINDOWS_USE_STDIO 1)
+ ENDIF (HDF5_ENABLE_WINDOWS_STDIO)
+ENDIF (WIN32)
+
+#-----------------------------------------------------------------------------
# Option to Build Shared/Static libs, default is static
#-----------------------------------------------------------------------------
OPTION (BUILD_SHARED_LIBS "Build Shared Libraries" OFF)