summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-10-25 16:52:58 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-10-25 16:52:58 (GMT)
commitc5e075851a9e7d2697b1e9ac77e8c18af595f332 (patch)
tree0e5548899989eefe4575667a135dc2b8e5c7945a /CMakeLists.txt
parentfa4ab23b9ec53375d13ca43daad741f25215be6f (diff)
downloadhdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.zip
hdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.tar.gz
hdf5-c5e075851a9e7d2697b1e9ac77e8c18af595f332.tar.bz2
[svn-r21667] Update FOLDER solution option for target properties. Added OPTION command for solution folder and no packaging.
Tested: local linux
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 16 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb051b0..6ad08f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,7 @@ PROJECT (HDF5 C CXX)
# # Add the sub project
# ADD_SUBDIRECTORY(Utilities/hdf5-1.8)
#-----------------------------------------------------------------------------
+
IF (BUILD_SHARED_LIBS)
SET (BUILD_NAME_EXT "SHARED")
ELSE (BUILD_SHARED_LIBS)
@@ -76,6 +77,21 @@ ELSE (BUILD_SHARED_LIBS)
ENDIF (BUILD_SHARED_LIBS)
#-----------------------------------------------------------------------------
+# Allow Visual Studio solution directories
+#-----------------------------------------------------------------------------
+# Provide a way for Visual Studio Express users to turn OFF the new FOLDER
+# organization feature. Default to ON for non-Express users. Express users must
+# explicitly turn off this option to build HDF5 in the Express IDE...
+#
+OPTION (HDF5_USE_FOLDERS "Enable folder grouping of projects in IDEs." ON)
+MARK_AS_ADVANCED (HDF5_USE_FOLDERS)
+IF (HDF5_USE_FOLDERS)
+ SET_PROPERTY (GLOBAL PROPERTY USE_FOLDERS ON)
+ENDIF (HDF5_USE_FOLDERS)
+OPTION (HDF5_NO_PACKAGES "CPACK - Disable packaging" OFF)
+MARK_AS_ADVANCED (HDF5_NO_PACKAGES)
+
+#-----------------------------------------------------------------------------
# Set the core names of all the libraries
#-----------------------------------------------------------------------------
SET (HDF5_LIB_CORENAME "hdf5")
@@ -220,11 +236,6 @@ ELSE (NOT HDF5_EXTERNALLY_CONFIGURED)
ENDIF (NOT HDF5_EXTERNALLY_CONFIGURED)
#-----------------------------------------------------------------------------
-# Allow Visual Studio solution directories
-#-----------------------------------------------------------------------------
-set_property(GLOBAL PROPERTY USE_FOLDERS ON)
-
-#-----------------------------------------------------------------------------
# Targets built within this project are exported at Install time for use
# by other projects using FindHDF5.
#-----------------------------------------------------------------------------
@@ -612,7 +623,6 @@ ENDIF (HDF5_ENABLE_SZIP_SUPPORT)
OPTION (HDF5_PACKAGE_EXTLIBS "CPACK - include external libraries" OFF)
IF (NOT HDF5_EXTERNALLY_CONFIGURED)
IF (HDF5_PACKAGE_EXTLIBS)
- SET (HDF5_NO_PACKAGES OFF CACHE BOOL "CPACK - Disable packaging" FORCE)
IF (HDF5_ENABLE_Z_LIB_SUPPORT AND ZLIB_FOUND)
PACKAGE_ZLIB_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT} ${LIB_TYPE})
ENDIF (HDF5_ENABLE_Z_LIB_SUPPORT AND ZLIB_FOUND)