summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-02-23 22:22:31 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-02-23 22:22:31 (GMT)
commit1773b327fb7611429a572020e4649b05358c911e (patch)
tree961156730747dfc9662ff61ecdb50c8b3a60aa5e /CMakeLists.txt
parent2129aa4c246b477c87139d754ef9d59647be8ef3 (diff)
downloadhdf5-1773b327fb7611429a572020e4649b05358c911e.zip
hdf5-1773b327fb7611429a572020e4649b05358c911e.tar.gz
hdf5-1773b327fb7611429a572020e4649b05358c911e.tar.bz2
Correct usage of add_compile_definitions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 487ca18..2bad805 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -564,9 +564,7 @@ endif ()
set (EXE_EXT "")
if (WIN32 OR MINGW)
set (EXE_EXT ".exe")
- add_compile_definitions (-D_BIND_TO_CURRENT_VCLIBS_VERSION=1)
- add_compile_definitions (-D_CRT_SECURE_NO_WARNINGS)
- add_compile_definitions (-D_CONSOLE)
+ add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CRT_SECURE_NO_WARNINGS _CONSOLE)
endif ()
if (MSVC)