summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2015-10-13 20:57:47 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2015-10-13 20:57:47 (GMT)
commit2c9b575d389760de5c09ab0acf43c4e990ef3fe4 (patch)
tree764efb4750014016d8902d5fe8d49b9328dd5cec /CMakeLists.txt
parent7c4e5533fb95574034de860105059996b5372013 (diff)
downloadhdf5-2c9b575d389760de5c09ab0acf43c4e990ef3fe4.zip
hdf5-2c9b575d389760de5c09ab0acf43c4e990ef3fe4.tar.gz
hdf5-2c9b575d389760de5c09ab0acf43c4e990ef3fe4.tar.bz2
[svn-r28056] Add HL and Threadsafe notice
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7da488..0eaba05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -571,6 +571,14 @@ if (WIN32)
message (STATUS " **** Allowing unsupported C++ and thread-safety options **** ")
endif (NOT ALLOW_UNSUPPORTED)
endif (HDF5_BUILD_CPP_LIB)
+ if (HDF5_BUILD_HL_LIB)
+ if (NOT ALLOW_UNSUPPORTED)
+ message (STATUS " **** HL and thread-safety options are not supported **** ")
+ message (STATUS " **** thread-safety option will not be used building HL library **** ")
+ else (NOT ALLOW_UNSUPPORTED)
+ message (STATUS " **** Allowing unsupported HL and thread-safety options **** ")
+ endif (NOT ALLOW_UNSUPPORTED)
+ endif (HDF5_BUILD_HL_LIB)
if (H5_HAVE_IOEO)
message (STATUS " **** Win32 threads requires WINVER>=0x600 (Windows Vista/7/8) **** ")
set (H5_HAVE_WIN_THREADS 1)