summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-10-19 18:34:31 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-10-19 18:34:31 (GMT)
commit494d39f1c2f6225c732cb857c860d6b475d03226 (patch)
tree92cfe66dbb8f35b9399d38550462d658243997bf /CMakeLists.txt
parent7e00924d1b9d235b988e63556e3f2c2644bae543 (diff)
downloadhdf5-494d39f1c2f6225c732cb857c860d6b475d03226.zip
hdf5-494d39f1c2f6225c732cb857c860d6b475d03226.tar.gz
hdf5-494d39f1c2f6225c732cb857c860d6b475d03226.tar.bz2
Move options to root cmake file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 53cddf7..e2fb000 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -913,4 +913,10 @@ endif ()
#-----------------------------------------------------------------------------
configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+#-----------------------------------------------------------------------------
+# Options for use by cross compiling and toolchains
+#-----------------------------------------------------------------------------
+option (HDF5_USE_PREGEN "Use pre-generated Files" OFF)
+option (HDF5_BATCH_H5DETECT "Use a batch command for running h5detect" OFF)
+
include (CMakeInstallation.cmake)