summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-23 22:14:21 (GMT)
committerM. Scot Breitenfeld <brtnfld@hdfgroup.org>2017-05-23 22:14:21 (GMT)
commit57ab1e7d6945c45107ebdd945bb89951ec90b8f1 (patch)
tree16c63b0b245704f89fd1ca9c1dfabfc82092bfb9 /CMakeLists.txt
parent69ccaee00a2778c7334587b6f6d51e16ff674ec9 (diff)
downloadhdf5-57ab1e7d6945c45107ebdd945bb89951ec90b8f1.zip
hdf5-57ab1e7d6945c45107ebdd945bb89951ec90b8f1.tar.gz
hdf5-57ab1e7d6945c45107ebdd945bb89951ec90b8f1.tar.bz2
add linking flag to cmake, does not fix the issue, still disabled shared with fortran
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce91052..b84cc7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -851,6 +851,11 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
option (SKIP_HDF5_FORTRAN_SHARED "Do not build the fortran shared libraries" OFF)
if (HDF5_BUILD_FORTRAN)
if (BUILD_SHARED_LIBS AND APPLE)
+ # Tell cmake to do the right thing with COMMON symbols, this fixes
+ # corrupt values with COMMON and EQUIVALENCE when building shared
+ # Fortran libraries on OSX with gnu and Intel compilers (HDFFV-2772).
+ # *** NOTE: Fix does not work with Cmake. ***
+ # set (HDF5_LINKER_FLAGS "-Wl,-commons,use_dylibs")
if (NOT ALLOW_UNSUPPORTED)
message (STATUS " **** Shared FORTRAN libraries are unsupported **** ")
set (SKIP_HDF5_FORTRAN_SHARED ON)