summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-08-13 15:53:09 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-08-13 15:53:09 (GMT)
commitdd2133f56e175700a3453e5e7464e57b650231b8 (patch)
tree8ee5e8cbe9db3e5c041554fa96f5d7ccf0e964f6 /CMakeLists.txt
parent5024051e35d4e113e7c144aed5b99f1be3cc938d (diff)
downloadhdf5-dd2133f56e175700a3453e5e7464e57b650231b8.zip
hdf5-dd2133f56e175700a3453e5e7464e57b650231b8.tar.gz
hdf5-dd2133f56e175700a3453e5e7464e57b650231b8.tar.bz2
Fixed Map API CMake option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e6474aa..eb22c7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -763,6 +763,9 @@ endif ()
# Option to build the map API
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_MAP_API "Build the map API" OFF)
+if (HDF5_ENABLE_MAP_API)
+ set (H5_HAVE_MAP_API 1)
+endif ()
#-----------------------------------------------------------------------------
# Add the HDF5 Library Target to the build