summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2019-08-13 18:15:55 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2019-08-13 18:15:55 (GMT)
commite42120c308b619e58f412e167f4449fd003f8ca9 (patch)
treef052711815038c7be77792d9b0fad60e69a478e3 /CMakeLists.txt
parent7b8ffecc20ad383627ea2dbfa86aaebdf5f5b76b (diff)
parentaeb145428f5e6bc51742fff031b0cf8cf6fbefbb (diff)
downloadhdf5-e42120c308b619e58f412e167f4449fd003f8ca9.zip
hdf5-e42120c308b619e58f412e167f4449fd003f8ca9.tar.gz
hdf5-e42120c308b619e58f412e167f4449fd003f8ca9.tar.bz2
Merging in latest from upstream (HDFFV/hdf5:refs/heads/develop)
* commit 'aeb145428f5e6bc51742fff031b0cf8cf6fbefbb': Updated h5trav.c to emit output that doesn't require ddl changes for map support. Fixed Map API CMake option Renamed H5Mdelete_key to H5Mdelete and H5Mset to H5Mput. Added ifdef for intel compilers, __GNUC__ has to be defined for header files which use it to work with intel compilers. This gives a warning for intel compiler about fallthrough, so added a check not to include fallthrough if using intel compilers. Added the map (H5M) API
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5921f1..a9a759f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -706,6 +706,7 @@ if (NOT HDF5_EXTERNALLY_CONFIGURED)
endif ()
endif ()
endif ()
+
#-----------------------------------------------------------------------------
# Option to use threadsafe
#-----------------------------------------------------------------------------
@@ -760,6 +761,14 @@ if (HDF5_ENABLE_THREADSAFE)
endif ()
#-----------------------------------------------------------------------------
+# Option to build the map API
+#-----------------------------------------------------------------------------
+option (HDF5_ENABLE_MAP_API "Build the map API" OFF)
+if (HDF5_ENABLE_MAP_API)
+ set (H5_HAVE_MAP_API 1)
+endif ()
+
+#-----------------------------------------------------------------------------
# Add the HDF5 Library Target to the build
#-----------------------------------------------------------------------------
add_subdirectory (src)