summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-09-25 21:43:57 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-09-25 21:43:57 (GMT)
commitff0881f35ba3de1077b168dd5383e487081a23bb (patch)
tree4960ddb7db6ee0297f5f5371af3b0ee6315f42a4 /CMakeLists.txt
parentaa08db839e6aea89487be985704d57a0e424b21b (diff)
downloadhdf5-ff0881f35ba3de1077b168dd5383e487081a23bb.zip
hdf5-ff0881f35ba3de1077b168dd5383e487081a23bb.tar.gz
hdf5-ff0881f35ba3de1077b168dd5383e487081a23bb.tar.bz2
OESS-98 merge with clang-format changes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 18 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d87c03..d0eebad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -409,6 +409,7 @@ include (${HDF_RESOURCES_EXT_DIR}/HDFMacros.cmake)
HDF_DIR_PATHS(${HDF5_PACKAGE_NAME})
include (${HDF_RESOURCES_EXT_DIR}/HDFLibMacros.cmake)
+include (${HDF_RESOURCES_DIR}/HDF5PluginMacros.cmake)
include (${HDF_RESOURCES_DIR}/HDF5Macros.cmake)
#-----------------------------------------------------------------------------
@@ -836,6 +837,17 @@ endif ()
#-----------------------------------------------------------------------------
add_subdirectory (src)
+#-----------------------------------------------------------------------------
+# Include filter plugins
+#-----------------------------------------------------------------------------
+include (CMakePlugins.cmake)
+
+if (HDF5_PACKAGE_EXTLIBS AND NOT HDF5_NO_PACKAGES)
+ if (HDF5_ENABLE_PLUGIN_SUPPORT AND PLUGIN_FOUND)
+ PACKAGE_PLUGIN_LIBRARY (${HDF5_ALLOW_EXTERNAL_SUPPORT})
+ endif ()
+endif ()
+
if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
if (ZLIB_FOUND AND ZLIB_USE_EXTERNAL)
if (NOT ONLY_SHARED_LIBS)
@@ -853,6 +865,11 @@ if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MAT
add_dependencies (${HDF5_LIBSH_TARGET} SZIP)
endif ()
endif ()
+ if (PLUGIN_FOUND AND PLUGIN_USE_EXTERNAL)
+ if (BUILD_SHARED_LIBS)
+ add_dependencies (PLUGIN ${HDF5_LIBSH_TARGET})
+ endif ()
+ endif ()
endif ()
#-----------------------------------------------------------------------------
@@ -1075,7 +1092,7 @@ endif ()
#-----------------------------------------------------------------------------
# Generate the H5pubconf.h file containing user settings needed by compilation
#-----------------------------------------------------------------------------
-configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_BINARY_DIR}/H5pubconf.h @ONLY)
+configure_file (${HDF_RESOURCES_DIR}/H5pubconf.h.in ${HDF5_SRC_BINARY_DIR}/H5pubconf.h @ONLY)
#-----------------------------------------------------------------------------
# Options for use by cross compiling and toolchains