summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-12-20 21:11:17 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-12-20 21:11:27 (GMT)
commit7e8923957fdf18ce95e4947145950e382cf0585a (patch)
treed9b44ca3d4c872e4f4b7175ce0a2558fa13d0177 /CMakeLists.txt
parent416f68c6709c9dd47620e89ac6c3a911e77e8b17 (diff)
downloadhdf5-7e8923957fdf18ce95e4947145950e382cf0585a.zip
hdf5-7e8923957fdf18ce95e4947145950e382cf0585a.tar.gz
hdf5-7e8923957fdf18ce95e4947145950e382cf0585a.tar.bz2
HDFFV-10656 Add CHECK_VOL support to CMake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2fb000..8433163 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -756,6 +756,13 @@ if (BUILD_TESTING)
mark_as_advanced (HDF5_TEST_FHEAP_VFD)
endif ()
+ option (HDF5_TEST_VOL "Execute tests with different VOLs" OFF)
+ mark_as_advanced (HDF5_TEST_VOL)
+ if (HDF5_TEST_VOL)
+ option (HDF5_TEST_FHEAP_VOL "Execute tests with different VOLs" ON)
+ mark_as_advanced (HDF5_TEST_FHEAP_VOL)
+ endif ()
+
option (HDF_TEST_EXPRESS "Control testing framework (0-3)" "0")
mark_as_advanced (HDF_TEST_EXPRESS)