summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorrawarren <richardwarren2@verizon.net>2021-11-29 21:25:23 (GMT)
committerGitHub <noreply@github.com>2021-11-29 21:25:23 (GMT)
commit720ddb20f347f5ea4e573c44f64e1886d1dc1038 (patch)
treebdd32da8424488f6d10221518c08ed907ac2be18 /CMakeLists.txt
parent9cdc6d58bdc0a8bce74559d15fae1284beb82033 (diff)
downloadhdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.zip
hdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.tar.gz
hdf5-720ddb20f347f5ea4e573c44f64e1886d1dc1038.tar.bz2
Add support for parallel tools based on the 3rd party library mpiFileUtils (libMFU) … (#1177)
Adds tool h5dwalk and configure options to enable building it. Co-authored-by: Richard Warren <Richard.Warren@hdfgroup.org> Co-authored-by: github-actions <41898282+github-actions[bot]@users.noreply.github.com> Co-authored-by: Richard.Warren <richard.warren@jelly.ad.hdfgroup.org> Co-authored-by: Larry Knox <lrknox@hdfgroup.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b5ff7f..dcee4f9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1007,6 +1007,31 @@ endif ()
# Option to build HDF5 Utilities
#-----------------------------------------------------------------------------
if (EXISTS "${HDF5_SOURCE_DIR}/utils" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/utils")
+ option (HDF5_BUILD_PARALLEL_TOOLS "Build Parallel HDF5 Tools" OFF)
+ if (HDF5_BUILD_PARALLEL_TOOLS AND HDF5_ENABLE_PARALLEL)
+ set (CMAKE_PREFIX_PATH "$HDF_RESOURCES_DIR")
+ find_package(MFU REQUIRED)
+ if (MFU_FOUND)
+ message(STATUS "LL_PATH=${LL_PATH}")
+ set (H5_HAVE_LIBMFU 1)
+ set (H5_HAVE_MFU_H 1)
+ set (CMAKE_REQUIRED_INCLUDES "${MFU_INCLUDE_DIR}")
+ set (MFU_LIBRARY_DEBUG "$MFU_LIBRARY")
+ set (MFU_LIBRARY_RELEASE "$MFU_LIBRARY")
+ endif ()
+ find_package(CIRCLE REQUIRED)
+ if (CIRCLE_FOUND)
+ set (H5_HAVE_LIBCIRCLE 1)
+ set (H5_HAVE_CIRCLE_H 1)
+ set (CMAKE_REQUIRED_INCLUDES "${CIRCLE_INCLUDE_DIR}")
+ endif ()
+ find_package(DTCMP REQUIRED)
+ if (DTCMP_FOUND)
+ set (H5_HAVE_LIBDTCMP 1)
+ set (H5_HAVE_DTCMP_H 1)
+ set (CMAKE_REQUIRED_INCLUDES "${DTCMP_INCLUDE_DIR}")
+ endif ()
+ endif ()
add_subdirectory (utils)
endif ()