summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjhendersonHDF <jhenderson@hdfgroup.org>2023-04-01 03:38:15 (GMT)
committerGitHub <noreply@github.com>2023-04-01 03:38:15 (GMT)
commit7b426bf3ea01e485f340a7119210136233aa8d29 (patch)
treefc39c6b1afa4b587585e51d3a4c01f08412f5387 /CMakeLists.txt
parent879575f3fa65138021a1e787fe41621d4e55bd47 (diff)
downloadhdf5-7b426bf3ea01e485f340a7119210136233aa8d29.zip
hdf5-7b426bf3ea01e485f340a7119210136233aa8d29.tar.gz
hdf5-7b426bf3ea01e485f340a7119210136233aa8d29.tar.bz2
CMake - Match Autotools behavior for library instrumentation (#2648)
Enable library instrumentation by default for parallel debug builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c2679dd..c46bbb1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -611,9 +611,15 @@ option (HDF5_BUILD_GENERATORS "Build Test Generators" OFF)
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_TRACE "Enable API tracing capability" OFF)
mark_as_advanced (HDF5_ENABLE_TRACE)
-if (${HDF_CFG_NAME} MATCHES "Debug")
+if (${HDF_CFG_NAME} MATCHES "Debug" OR ${HDF_CFG_NAME} MATCHES "Developer")
# Enable instrumenting of the library's internal operations
option (HDF5_ENABLE_INSTRUMENT "Instrument The library" OFF)
+
+ # Instrumenting is enabled by default for parallel debug builds
+ if (HDF5_ENABLE_PARALLEL)
+ set (HDF5_ENABLE_INSTRUMENT ON CACHE BOOL "Instrument The library" FORCE)
+ endif ()
+
if (HDF5_ENABLE_INSTRUMENT)
set (H5_HAVE_INSTRUMENTED_LIBRARY 1)
endif ()