summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2013-12-19 14:55:17 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2013-12-19 14:55:17 (GMT)
commit92d4f32514e05a3cff1db0af0befcd489c74c1d3 (patch)
tree836a2a311c4ceb9acdf968eb765215507d25d413 /CMakeLists.txt
parent6a77f9821bcf0578a3bd310131bcc6757f7a0f04 (diff)
downloadhdf5-92d4f32514e05a3cff1db0af0befcd489c74c1d3.zip
hdf5-92d4f32514e05a3cff1db0af0befcd489c74c1d3.tar.gz
hdf5-92d4f32514e05a3cff1db0af0befcd489c74c1d3.tar.bz2
[svn-r24588] Add sunos compile option changes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index da003c5..bd84c71 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -283,6 +283,9 @@ ELSE (BUILD_SHARED_LIBS)
IF (NOT WIN32)
# should this be a user setting : Everyone uses it anyway ?
ADD_DEFINITIONS (-DPIC)
+ IF (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ ADD_DEFINITIONS (-KPIC)
+ ENDIF (${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
ENDIF (NOT WIN32)
ENDIF (BUILD_SHARED_LIBS)
@@ -461,7 +464,11 @@ ENDIF (HDF5_DISABLE_COMPILER_WARNINGS)
# break into groups (from the config/gnu-flags file)
#-----------------------------------------------------------------------------
IF (NOT MSVC)
- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -W -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
+ IF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wextra -Wundef -Wshadow -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Wconversion -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline")
+ ELSE (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
+ SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -erroff=%none -DBSD_COMP")
+ ENDIF (NOT ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
# Append warning flags
# Don't use the '-Wtraditional' flag, we're way past having K&R C code
# SET (H5_CFLAGS "${H5_CFLAGS} -Wtraditional")