summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichel Zou <xantares09@hotmail.com>2020-10-30 12:09:23 (GMT)
committerMichel Zou <xantares09@hotmail.com>2020-10-30 15:09:28 (GMT)
commit0db1fe81d58e6926b3e5982dd0329fc95faf2c8e (patch)
tree55f882d7714863bbaa74e20ed09fca97fb88d277 /CMakeLists.txt
parent6c0f954d683142e123baa4d48f5a69d5e20aa11d (diff)
downloadhdf5-0db1fe81d58e6926b3e5982dd0329fc95faf2c8e.zip
hdf5-0db1fe81d58e6926b3e5982dd0329fc95faf2c8e.tar.gz
hdf5-0db1fe81d58e6926b3e5982dd0329fc95faf2c8e.tar.bz2
CMake: MINGW implies WIN32
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0eebad..01355dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,10 +572,11 @@ endif ()
# Certain systems may add /Debug or /Release to output paths
# and we need to call the executable from inside the CMake configuration
#-----------------------------------------------------------------------------
-set (EXE_EXT "")
-if (WIN32 OR MINGW)
- set (EXE_EXT ".exe")
- add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CRT_SECURE_NO_WARNINGS _CONSOLE)
+if (WIN32)
+ add_compile_definitions (_CRT_SECURE_NO_WARNINGS)
+ if (MSVC)
+ add_compile_definitions (_BIND_TO_CURRENT_VCLIBS_VERSION=1 _CONSOLE)
+ endif ()
endif ()
if (MSVC)
@@ -777,7 +778,7 @@ endif ()
option (HDF5_ENABLE_THREADSAFE "Enable thread-safety" OFF)
if (HDF5_ENABLE_THREADSAFE)
# check for unsupported options
- if (WIN32 OR MINGW)
+ if (WIN32)
message (STATUS " **** thread-safety option not supported with static library **** ")
message (STATUS " **** thread-safety option will not be used building static library **** ")
endif ()