summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJordan Henderson <jhenderson@hdfgroup.org>2018-07-31 15:45:43 (GMT)
committerJordan Henderson <jhenderson@hdfgroup.org>2018-07-31 15:45:43 (GMT)
commit5e138dc1e91a4ec61d9383397e0e11c6bbbcbe5e (patch)
tree1dbfe9561d74457ea7d2bd2de294e89679a4f307 /CMakeLists.txt
parent256fc4754b02dc2f684c792e48a913de15a2fc52 (diff)
downloadhdf5-5e138dc1e91a4ec61d9383397e0e11c6bbbcbe5e.zip
hdf5-5e138dc1e91a4ec61d9383397e0e11c6bbbcbe5e.tar.gz
hdf5-5e138dc1e91a4ec61d9383397e0e11c6bbbcbe5e.tar.bz2
Add hdf5settings section for parallel compression status in CMake builds
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74c7095..0302f4f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -561,11 +561,13 @@ if (HDF5_ENABLE_PARALLEL)
CHECK_SYMBOL_EXISTS (MPI_Info_c2f "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_MULTI_LANG_Info)
# Used by Parallel Compression feature
+ set (PARALLEL_FILTERED_WRITES ON)
CHECK_SYMBOL_EXISTS (MPI_Mprobe "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Mprobe)
CHECK_SYMBOL_EXISTS (MPI_Imrecv "${MPI_C_INCLUDE_DIRS}/mpi.h" H5_HAVE_MPI_Imrecv)
if (NOT H5_HAVE_MPI_Mprobe OR NOT H5_HAVE_MPI_Imrecv)
message (WARNING "The MPI_Mprobe and/or MPI_Imrecv functions could not be located.
Parallel writes of filtered data will be disabled.")
+ set (PARALLEL_FILTERED_WRITES OFF)
endif ()
else ()
message (STATUS "Parallel libraries not found")