summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2022-02-17 16:05:08 (GMT)
committerGitHub <noreply@github.com>2022-02-17 16:05:08 (GMT)
commit08ec5b45a5c069077087351923afe780488421a3 (patch)
tree5511f7619f1a7cb4e5402a3f0736124ab1a66f0c /CMakeLists.txt
parentbbb0acf353920f8315ad59e80e9e8d0754cca655 (diff)
downloadhdf5-08ec5b45a5c069077087351923afe780488421a3.zip
hdf5-08ec5b45a5c069077087351923afe780488421a3.tar.gz
hdf5-08ec5b45a5c069077087351923afe780488421a3.tar.bz2
Add SZ filter and adjust compression file names to avoid conflicts (#1434)
* Updated plugins project required adjustments * Updated plugins need to distinguish external libs * Fix missed rename * Use same name for windows as linux - avoid name clash
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 59595b6..fedce44 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -895,10 +895,10 @@ add_subdirectory (src)
if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "TGZ")
if (ZLIB_FOUND AND ZLIB_USE_EXTERNAL)
if (NOT ONLY_SHARED_LIBS)
- add_dependencies (${HDF5_LIB_TARGET} ZLIB)
+ add_dependencies (${HDF5_LIB_TARGET} HDF5_ZLIB)
endif ()
if (BUILD_SHARED_LIBS)
- add_dependencies (${HDF5_LIBSH_TARGET} ZLIB)
+ add_dependencies (${HDF5_LIBSH_TARGET} HDF5_ZLIB)
endif ()
endif ()
if (SZIP_FOUND AND SZIP_USE_EXTERNAL)