summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2024-01-29 19:13:33 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2024-02-14 21:32:01 (GMT)
commit30b0f89f869c947cce41dbdb983533400f607604 (patch)
tree50e930c644f08585e074693bc8b6429a603c682b /CMakeLists.txt
parent56d9be146fb27456e4c517e49ccf920396824d71 (diff)
downloadhdf5-30b0f89f869c947cce41dbdb983533400f607604.zip
hdf5-30b0f89f869c947cce41dbdb983533400f607604.tar.gz
hdf5-30b0f89f869c947cce41dbdb983533400f607604.tar.bz2
Add API support for Fortran MPI_F08 module definitions. (#3959)
* revert to using c-stub for _F08 MPI APIs * use mpi compiler wrappers for cmake and nvhpc
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f17f0e1..7a35aa5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1077,6 +1077,13 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
if (MPI_Fortran_LINK_FLAGS)
set (CMAKE_Fortran_EXE_LINKER_FLAGS "${MPI_Fortran_LINK_FLAGS} ${CMAKE_EXE_LINKER_FLAGS}")
endif ()
+ # Check if MPI-3 Fortran 2008 module mpi_f08 is supported
+ if (MPI_Fortran_HAVE_F08_MODULE)
+ set (H5_HAVE_MPI_F08 1)
+ message (VERBOSE "MPI-3 Fortran 2008 module mpi_f08 is supported")
+ else ()
+ message (VERBOSE "MPI-3 Fortran 2008 module mpi_f08 is NOT supported")
+ endif ()
endif ()
#option (HDF5_INSTALL_MOD_FORTRAN "Copy FORTRAN mod files to include directory (NO SHARED STATIC)" "NO")