summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-04-24 15:25:13 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-04-24 15:25:13 (GMT)
commitb3c5284692093953132c6c8227e0980b670bf4ad (patch)
tree84cc1f217108c4585586ffd6e74782cbe91734ed /CMakeLists.txt
parentfa829e322ed44a67e2b3f2d6adf1306ad794859b (diff)
parentf435ed67fa53ca35462a60f4025464465d7dc9d0 (diff)
downloadhdf5-b3c5284692093953132c6c8227e0980b670bf4ad.zip
hdf5-b3c5284692093953132c6c8227e0980b670bf4ad.tar.gz
hdf5-b3c5284692093953132c6c8227e0980b670bf4ad.tar.bz2
Merge pull request #1038 in HDFFV/hdf5 from ~BYRN/hdf5_adb:develop to develop
* commit 'f435ed67fa53ca35462a60f4025464465d7dc9d0': TRILABS-20 set a compiler name on all project commands TRILABS-19 All c code INCLUDE_DIRECTORIES converted TRILABS-19 Initial conversion of include_directories to targets
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0da475a..d3afc41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required (VERSION 3.10)
-PROJECT (HDF5 C CXX)
+project (HDF5 C)
#-----------------------------------------------------------------------------
# Instructions for use : Normal Build
@@ -555,11 +555,6 @@ endif ()
include (${HDF_RESOURCES_DIR}/HDFCompilerFlags.cmake)
#-----------------------------------------------------------------------------
-# All libs/tests/examples need the main include directories
-#-----------------------------------------------------------------------------
-INCLUDE_DIRECTORIES (${HDF5_BINARY_DIR} ${HDF5_SRC_DIR} ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
-
-#-----------------------------------------------------------------------------
# Option to Enable MPI Parallel
#-----------------------------------------------------------------------------
set (CMAKE_MODULE_PATH ${HDF_RESOURCES_DIR} ${HDF_RESOURCES_EXT_DIR} ${CMAKE_MODULE_PATH})