summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2021-09-10 12:40:27 (GMT)
committerGitHub <noreply@github.com>2021-09-10 12:40:27 (GMT)
commitb58f8540ac3c416e1d833aad243a0df35ec4a616 (patch)
treefb160575a2cc88c8341f9115c3f66a9286e00d7c /CMakeLists.txt
parent8e06298ecfde5eb647b39cfe0dab70005f092199 (diff)
downloadhdf5-b58f8540ac3c416e1d833aad243a0df35ec4a616.zip
hdf5-b58f8540ac3c416e1d833aad243a0df35ec4a616.tar.gz
hdf5-b58f8540ac3c416e1d833aad243a0df35ec4a616.tar.bz2
Fix various warnings and issues in doxygen doc generation (#994)
* Fix various warnings and issues in doxygen doc generation * Add new file to list
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 15 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c44c5d5..13f2e35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -572,20 +572,6 @@ endif ()
# endif ()
#-----------------------------------------------------------------------------
-# Option to build documentation
-#-----------------------------------------------------------------------------
-option (HDF5_BUILD_DOC "Build documentation" OFF)
-if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOXYGEN_DIR}")
-# check if Doxygen is installed
- find_package(Doxygen)
- if (DOXYGEN_FOUND)
- message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
- else ()
- message(STATUS "Doxygen needs to be installed to generate the doxygen documentation")
- endif ()
-endif ()
-
-#-----------------------------------------------------------------------------
# Option to indicate using a memory checker
#-----------------------------------------------------------------------------
option (HDF5_ENABLE_USING_MEMCHECKER "Indicate that a memory checker is used" OFF)
@@ -926,6 +912,21 @@ if (HDF5_ALLOW_EXTERNAL_SUPPORT MATCHES "GIT" OR HDF5_ALLOW_EXTERNAL_SUPPORT MAT
endif ()
#-----------------------------------------------------------------------------
+# Option to build documentation
+#-----------------------------------------------------------------------------
+option (HDF5_BUILD_DOC "Build documentation" OFF)
+if (HDF5_BUILD_DOC AND EXISTS "${HDF5_DOXYGEN_DIR}" AND IS_DIRECTORY "${HDF5_DOXYGEN_DIR}")
+# check if Doxygen is installed
+ find_package(Doxygen)
+ if (DOXYGEN_FOUND)
+ message(STATUS "Doxygen version: ${DOXYGEN_VERSION}")
+ add_subdirectory (doxygen)
+ else ()
+ message(STATUS "Doxygen needs to be installed to generate the doxygen documentation")
+ endif ()
+endif ()
+
+#-----------------------------------------------------------------------------
# Dashboard and Testing Settings
#-----------------------------------------------------------------------------
option (BUILD_TESTING "Build HDF5 Unit Testing" ON)