summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-02 19:04:25 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-07-02 19:04:25 (GMT)
commit2a567e8155a883a1d79a7879e953449ed7505945 (patch)
tree8daf5836b2aeb494880ca54672574ad13b4b4a17 /CMakeLists.txt
parente2bbdddff758e14a27a3f6a7d47f2bfc8041c687 (diff)
downloadhdf5-2a567e8155a883a1d79a7879e953449ed7505945.zip
hdf5-2a567e8155a883a1d79a7879e953449ed7505945.tar.gz
hdf5-2a567e8155a883a1d79a7879e953449ed7505945.tar.bz2
[svn-r27326] Working version of cmake on linux.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 33b4bca..e638ba1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -638,6 +638,7 @@ if (EXISTS "${HDF5_SOURCE_DIR}/fortran" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/for
endif (BUILD_SHARED_LIBS AND APPLE)
option (HDF5_ENABLE_F2003 "Enable FORTRAN 2003 Standard" ON)
include (${HDF_RESOURCES_EXT_DIR}/HDFUseFortran.cmake)
+ include (${HDF_RESOURCES_DIR}/HDF5UseFortran.cmake)
if (HDF5_ENABLE_F2003)
if (NOT FORTRAN_HAVE_ISO_C_BINDING)
set (HDF5_ENABLE_F2003 OFF)
@@ -686,6 +687,7 @@ endif (EXISTS "${HDF5_SOURCE_DIR}/c++" AND IS_DIRECTORY "${HDF5_SOURCE_DIR}/c++"
# Check if Fortran's default real is double precision. If it is and HL is
# being built then configure should fail due to bug HDFFV-889.
#-----------------------------------------------------------------------------
+
if (HDF5_BUILD_FORTRAN AND HDF5_BUILD_HL_LIB )
if (NOT FORTRAN_DEFAULT_REAL_NOT_DOUBLE)
message (FATAL_ERROR " **** Fortran high-level routines are not supported when the default REAL is DOUBLE PRECISION, use HDF5_BUILD_HL_LIB:BOOL=OFF **** ")
d colspan='5'> * Added Fortran Async APIs (#2715)Scot Breitenfeld2023-04-2139-2666/+6146 * Comment cleanup (#2689)Quincey Koziol2023-04-118-34/+0 * Make sure that ONLY_SHARED_LIBS option is correctly set (#2544)Allen Byrne2023-03-132-14/+14 * Fix new codespell issues (#2521)Mark Kittisopikul2023-03-082-2/+2 * CMake generated pkg-config file is incorrect #2259 (#2476)Allen Byrne2023-02-171-2/+6 * Pass-through connector testing flexibility (#2399)Quincey Koziol2023-01-091-1/+1 * Update FORTRAN VOL connector test for external pass-through testing (#2393)Quincey Koziol2023-01-051-1/+3 * Fix doxygen warnings and remove javadocs (#2324)Allen Byrne2022-12-201-25/+0 * fixed unclosed objects in test (#2290)Scot Breitenfeld2022-12-101-6/+10 * Correct requires setting for pkgconfig files (#2280)Allen Byrne2022-12-071-2/+2 * Update copyright headers (#2184)Larry Knox2022-11-01106-149/+43 * Removed the file, func, line args in the _async APIs fpr doxygen (#2179)Scot Breitenfeld2022-10-257-24/+24 * Implement option for using CMake GNUInstallDirs (#2175)Allen Byrne2022-10-251-3/+3 * Multi Dataset (#2120)Neil Fortner2022-10-1910-18/+630 * address test failing when default real and integers are 8 bytes (#2173)Scot Breitenfeld2022-10-191-6/+17 * changed to referencing C APIs by empty brackets (Fortran) (#2167)Scot Breitenfeld2022-10-1714-396/+396 * Fix H5Dfill_f test (#2162)Scot Breitenfeld2022-10-144-126/+188 * renamed H5_FORTRAN_C_LONG_DOUBLE_IS_UNIQUE DLL (#2158)Scot Breitenfeld2022-10-132-2/+2 * Fix for missing h5dfill_c_long_double in dll (#2155)Scot Breitenfeld2022-10-122-1/+4 * Implemented C matching (and general) H5Dfill Fortran wrappers (#2152)Scot Breitenfeld2022-10-116-70/+393 * Avoid calling H5FD_subfiling_init from h5open_f. (#2149)Scot Breitenfeld2022-10-071-1/+23 * Subfiling Fortran wrapper work. (#2143)Scot Breitenfeld2022-10-0616-34/+868 * Grouped the Fortran constants in Doxygen (#2136)Scot Breitenfeld2022-10-036-67/+104 * Misc. Fortran Doxygen updates (#2129)Scot Breitenfeld2022-09-288-283/+271 * Added C references to Fortran constants. (#2126)Scot Breitenfeld2022-09-2716-425/+1077 * develop Merge doxygen from 1.12 branch (#2095)Allen Byrne2022-09-14