summaryrefslogtreecommitdiffstats
path: root/CMakePresets.json
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2024-02-15 22:51:33 (GMT)
committerGitHub <noreply@github.com>2024-02-15 22:51:33 (GMT)
commit413d10f6e3d4db5341413ba7cd4f819eb5156a51 (patch)
tree8741384bb37a09d0e8d31116c64d9065a0b046f3 /CMakePresets.json
parent987a734e759c82c65a661ae6090b2252d63a7aec (diff)
parent424cb6ecd35bc262120e250ee25706c3d3c3c15d (diff)
downloadhdf5-413d10f6e3d4db5341413ba7cd4f819eb5156a51.zip
hdf5-413d10f6e3d4db5341413ba7cd4f819eb5156a51.tar.gz
hdf5-413d10f6e3d4db5341413ba7cd4f819eb5156a51.tar.bz2
Merge pull request #4019 from lrknox/1_14_dev_sync2_lrk
* Update upload- artifact to match download version (#3929) * Reorg and update options for doc and cmake config (#3934) * Add binary build for linux S3 (#3936) * Clean up Doxygen for szip functions and constants (#3943) * Replace off_t with HDoff_t internally (#3944) off_t is a 32-bit signed value on Windows, so we should use HDoff_t (which is __int64 on Windows) internally instead. Also defines HDftell on Windows to be _ftelli64(). * Fix chid_t to hid_t (#3948) * Fortran API work. (#3941) * - Added Fortran APIs: H5FGET_INTENT_F, H5SSELECT_ITER_CREATE_F, H5SSEL_ITER_GET_SEQ_LIST_F, H5SSELECT_ITER_CLOSE_F, H5S_mp_H5SSELECT_ITER_RESET_F - Added Fortran Parameters: H5S_SEL_ITER_GET_SEQ_LIST_SORTED_F, H5S_SEL_ITER_SHARE_WITH_DATASPACE_F - Added tests for new APIs - Removed H5F C wrapper stubs - Documentation misc. cleanup. * Add the user test program in HDFFV-9174 for committed types. (#3937) Add the user test program for committed types in HDFFV-9174 * Remove cached datatype conversion path table entries on file close (#3942) * fixed BIND name (#3957) * update H5Ssel_iter_reset_f test * Change 'extensible' to 'fixed' in H5FA code (#3964) * RF: move codespell configuration into .codespellrc so could be used locally as well (#3958) * Add RELEASE.txt note for the fix for issue #1256 (#3955) * Fix doxygen errors (#3962) * Add API support for Fortran MPI_F08 module definitions. (#3959) * revert to using c-stub for _F08 MPI APIs * use mpi compiler wrappers for cmake and nvhpc * Added a GitHub Codespaces configuration. (#3966) * Fixed XL and gfortran errors (#3968) * h5 compiler wrappers now pass all arguments passed to it to the compile line (#3954) * The issue was that the "allargs" variable was not being used in the final command of the compiler wrapper. Any entries containing an escaped quote (\", \') or other non-matching argument (*) would not be passed to the compile line. I have fixed this problem by ensuring all arguments passed to the compiler wrapper are now included in the compile line. * Add binary testing to CI testing (#3971) * Replace 'T2' with ' ' to avoid failure to match expected output due to (#3975) * Clarify vlen string datatype message (#3950) * append '-WF,' when passing C preprocessor directives to the xlf compiler (#3976) * Create CITATION.cff (#3927) Add citation source based on http://web.archive.org/web/20230610185232/https://portal.hdfgroup.org/display/knowledge/How+do+I+properly+cite+HDF5%The space difference in the Fortran examples must be fixed to match the expected output for compression filter examples. * corrected warning: implicit conversion changes signedness (#3982) * Skip mac bintest until more reliable (#3983) * Make platform specific test presets for windows and macs (#3988) * chore: fix typo (#3989) * Add a missing left parenthesis in RELEASE.txt. (#3990) * Remove ADB signature from RELEASE.txt. (#3986) * Bump the github-actions group with 6 updates (#3981) * Sync API tests with vol-tests (#3940) * Fix for github issue #2414: segfault when copying dataset with attrib… (#3967) * Fix for github issue #2414: segfault when copying dataset with attributes. This also fixes github issue #3241: segfault when copying dataset. Need to set the location via H5T_set_loc() of the src datatype when copying dense attributes. Otherwise the vlen callbacks are not set up therefore causing seg fault when doing H5T_convert() -> H5T__conv_vlen(). * Fix broken links caused by examples relocation. (#3995) * Add abi-complience check and upload to releases (#3996) * Fix h5watch test failures to ignore system warnings on ppc64le. (#3997) * Remove oneapi/clang compiler printf() type warning. (#3994) * Updated information about obtaining the HDF5 source code to use the repos. (#3972) * Fix overwritten preset names (#4000) * Fix incompatible pointer type warnings in object reference examples (#3999) * Fix build issue and some warnings in H5_api_dataset_test.c (#3998) * Modern C++ dtor declarations (#1830) * C++ dtor modernization - Replaced a bunch of empty dtors with `= default` - Removed deprecated `throw()`. In C++11, dtors are `noexcept` by default. * remove incorrect check for environ (#4002) * Add a missing file into Makefile.am for MinGW Autotools build error. (#4004) * Issue #1824: Replaced most remaining sprintf with safer snprint (#4003) * Add hl and cpp ABI reports to daily build (#4006) * Don't add files and directories with names that begin with ., or that match *autom4te* to release tar & zip files. (#4009) * Fix some output issues with ph5diff (#4008) * Update install texts (#4010) * Add C in project line for CMake to fix #4012. (#4014) * separate out individual checks for string removal (#4015) * Add compound subset ops on attributes to API tests (#4005) ---------
Diffstat (limited to 'CMakePresets.json')
-rw-r--r--CMakePresets.json96
1 files changed, 94 insertions, 2 deletions
diff --git a/CMakePresets.json b/CMakePresets.json
index 84b4f2f..61afadd 100644
--- a/CMakePresets.json
+++ b/CMakePresets.json
@@ -94,6 +94,14 @@
}
},
{
+ "name": "ci-S3",
+ "hidden": true,
+ "cacheVariables": {
+ "HDF5_ENABLE_ROS3_VFD": "ON",
+ "HDF5_ENABLE_HDFS": "OFF"
+ }
+ },
+ {
"name": "ci-StdShar",
"hidden": true,
"inherits": ["ci-StdCompression", "ci-StdExamples", "ci-StdPlugins"],
@@ -150,6 +158,14 @@
]
},
{
+ "name": "ci-StdShar-GNUC-S3",
+ "description": "GNUC S3 Config for x64 (Release)",
+ "inherits": [
+ "ci-StdShar-GNUC",
+ "ci-S3"
+ ]
+ },
+ {
"name": "ci-StdShar-Intel",
"description": "Intel Standard Config for x64 (Release)",
"inherits": [
@@ -188,6 +204,15 @@
]
},
{
+ "name": "ci-StdShar-GNUC-S3",
+ "description": "GNUC S3 Build for x64 (Release)",
+ "configurePreset": "ci-StdShar-GNUC-S3",
+ "verbose": true,
+ "inherits": [
+ "ci-x64-Release-GNUC"
+ ]
+ },
+ {
"name": "ci-StdShar-Intel",
"description": "Intel Standard Build for x64 (Release)",
"configurePreset": "ci-StdShar-Intel",
@@ -218,6 +243,23 @@
]
},
{
+ "name": "ci-StdShar-OSX-Clang",
+ "configurePreset": "ci-StdShar-Clang",
+ "inherits": [
+ "ci-x64-Release-Clang"
+ ],
+ "execution": {
+ "noTestsAction": "error",
+ "timeout": 180,
+ "jobs": 2
+ },
+ "condition": {
+ "type": "equals",
+ "lhs": "${hostSystemName}",
+ "rhs": "Darwin"
+ }
+ },
+ {
"name": "ci-StdShar-GNUC",
"configurePreset": "ci-StdShar-GNUC",
"inherits": [
@@ -225,7 +267,14 @@
]
},
{
- "name": "ci-StdShar-Intel",
+ "name": "ci-StdShar-GNUC-S3",
+ "configurePreset": "ci-StdShar-GNUC-S3",
+ "inherits": [
+ "ci-x64-Release-GNUC"
+ ]
+ },
+ {
+ "name": "ci-StdShar-win-Intel",
"configurePreset": "ci-StdShar-Intel",
"inherits": [
"ci-x64-Release-Intel"
@@ -234,7 +283,19 @@
"exclude": {
"name": "H5DUMP-tfloatsattrs"
}
+ },
+ "condition": {
+ "type": "equals",
+ "lhs": "${hostSystemName}",
+ "rhs": "Windows"
}
+ },
+ {
+ "name": "ci-StdShar-Intel",
+ "configurePreset": "ci-StdShar-Intel",
+ "inherits": [
+ "ci-x64-Release-Intel"
+ ]
}
],
"packagePresets": [
@@ -254,6 +315,11 @@
"inherits": "ci-x64-Release-GNUC"
},
{
+ "name": "ci-StdShar-GNUC-S3",
+ "configurePreset": "ci-StdShar-GNUC-S3",
+ "inherits": "ci-x64-Release-GNUC"
+ },
+ {
"name": "ci-StdShar-Intel",
"configurePreset": "ci-StdShar-Intel",
"inherits": "ci-x64-Release-Intel"
@@ -279,6 +345,15 @@
]
},
{
+ "name": "ci-StdShar-OSX-Clang",
+ "steps": [
+ {"type": "configure", "name": "ci-StdShar-Clang"},
+ {"type": "build", "name": "ci-StdShar-Clang"},
+ {"type": "test", "name": "ci-StdShar-OSX-Clang"},
+ {"type": "package", "name": "ci-StdShar-Clang"}
+ ]
+ },
+ {
"name": "ci-StdShar-GNUC",
"steps": [
{"type": "configure", "name": "ci-StdShar-GNUC"},
@@ -288,6 +363,15 @@
]
},
{
+ "name": "ci-StdShar-GNUC-S3",
+ "steps": [
+ {"type": "configure", "name": "ci-StdShar-GNUC-S3"},
+ {"type": "build", "name": "ci-StdShar-GNUC-S3"},
+ {"type": "test", "name": "ci-StdShar-GNUC-S3"},
+ {"type": "package", "name": "ci-StdShar-GNUC-S3"}
+ ]
+ },
+ {
"name": "ci-StdShar-Intel",
"steps": [
{"type": "configure", "name": "ci-StdShar-Intel"},
@@ -295,7 +379,15 @@
{"type": "test", "name": "ci-StdShar-Intel"},
{"type": "package", "name": "ci-StdShar-Intel"}
]
+ },
+ {
+ "name": "ci-StdShar-win-Intel",
+ "steps": [
+ {"type": "configure", "name": "ci-StdShar-Intel"},
+ {"type": "build", "name": "ci-StdShar-Intel"},
+ {"type": "test", "name": "ci-StdShar-win-Intel"},
+ {"type": "package", "name": "ci-StdShar-Intel"}
+ ]
}
]
}
-