summaryrefslogtreecommitdiffstats
path: root/HDF5Examples/C/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2024-01-03 17:23:42 (GMT)
committerGitHub <noreply@github.com>2024-01-03 17:23:42 (GMT)
commit72e33ad7727765fd162a1f70ca502cc2437aabde (patch)
tree84b4cff56687fa7a8d443a529984932dd30a7fa4 /HDF5Examples/C/CMakeLists.txt
parent95827bc79d592ad5aa71ec3199a83ede9b324c20 (diff)
downloadhdf5-72e33ad7727765fd162a1f70ca502cc2437aabde.zip
hdf5-72e33ad7727765fd162a1f70ca502cc2437aabde.tar.gz
hdf5-72e33ad7727765fd162a1f70ca502cc2437aabde.tar.bz2
Merge examples and workflows from develop (#3918)
Diffstat (limited to 'HDF5Examples/C/CMakeLists.txt')
-rw-r--r--HDF5Examples/C/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/HDF5Examples/C/CMakeLists.txt b/HDF5Examples/C/CMakeLists.txt
new file mode 100644
index 0000000..4e589bc
--- /dev/null
+++ b/HDF5Examples/C/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required (VERSION 3.12)
+PROJECT (HDF5Examples_C)
+
+#-----------------------------------------------------------------------------
+# Build the C Examples
+#-----------------------------------------------------------------------------
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5D)
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5G)
+add_subdirectory (${PROJECT_SOURCE_DIR}/H5T)
+
+if (${H5_LIBVER_DIR} GREATER 16)
+# add_subdirectory (${PROJECT_SOURCE_DIR}/Perf)
+ if (USE_SHARED_LIBS AND HDF_BUILD_FILTERS AND HDF5_ENABLE_PLUGIN_SUPPORT)
+ add_subdirectory (${PROJECT_SOURCE_DIR}/H5FLT)
+ endif ()
+endif ()
+
+if (${H5_LIBVER_DIR} GREATER 110)
+ add_subdirectory (${PROJECT_SOURCE_DIR}/H5VDS)
+endif ()
+
+if (H5_HAVE_PARALLEL AND HDF5_ENABLE_PARALLEL)
+ add_subdirectory (${PROJECT_SOURCE_DIR}/H5PAR)
+endif ()