summaryrefslogtreecommitdiffstats
path: root/HDF5Examples/C/H5VDS/Makefile.am
diff options
context:
space:
mode:
authorAllen Byrne <50328838+byrnHDF@users.noreply.github.com>2023-12-21 15:53:24 (GMT)
committerGitHub <noreply@github.com>2023-12-21 15:53:24 (GMT)
commitaa734a5d7e19c0eb9232e55a2f257fd87ffee0f1 (patch)
tree4ae5cdc2ab39a1b73813203c194c72c9abcd3a42 /HDF5Examples/C/H5VDS/Makefile.am
parent773245a0847e6b482f28b919fe4ed29b0f366834 (diff)
downloadhdf5-aa734a5d7e19c0eb9232e55a2f257fd87ffee0f1.zip
hdf5-aa734a5d7e19c0eb9232e55a2f257fd87ffee0f1.tar.gz
hdf5-aa734a5d7e19c0eb9232e55a2f257fd87ffee0f1.tar.bz2
Add VDS examples and fix non-standalone build (#3898)
* Choose a size for rdata dimension * Fix platform naming conflicts * Fix doxygen references to point within library repo
Diffstat (limited to 'HDF5Examples/C/H5VDS/Makefile.am')
-rw-r--r--HDF5Examples/C/H5VDS/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/HDF5Examples/C/H5VDS/Makefile.am b/HDF5Examples/C/H5VDS/Makefile.am
new file mode 100644
index 0000000..e4f5320
--- /dev/null
+++ b/HDF5Examples/C/H5VDS/Makefile.am
@@ -0,0 +1,51 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+
+noinst_PROGRAMS = \
+ h5ex_vds \
+ h5ex_vds-exc \
+ h5ex_vds-exclim \
+ h5ex_vds-eiger \
+ h5ex_vds-simpleIO \
+ h5ex_vds-percival \
+ h5ex_vds-percival-unlim \
+ h5ex_vds-percival-unlim-maxmin
+
+
+EXTRA_DIST = \
+ tfiles/h5ex_vds.tst \
+ tfiles/h5ex_vds-exc.tst \
+ tfiles/h5ex_vds-exclim.tst \
+ tfiles/h5ex_vds-eiger.tst \
+ tfiles/h5ex_vds-simpleIO.tst \
+ tfiles/h5ex_vds-percival.tst \
+ tfiles/h5ex_vds-percival-unlim.tst \
+ tfiles/h5ex_vds-percival-unlim-maxmin.tst \
+ tfiles/h5ex_vds.ddl \
+ tfiles/h5ex_vds-exc.ddl \
+ tfiles/h5ex_vds-exclim.ddl \
+ tfiles/h5ex_vds-eiger.ddl \
+ tfiles/h5ex_vds-simpleIO.ddl \
+ tfiles/h5ex_vds-percival.ddl \
+ tfiles/h5ex_vds-percival-unlim.ddl \
+ tfiles/h5ex_vds-percival-unlim-maxmin.ddl \
+ test.sh
+
+TESTS = test.sh
+
+CLEANFILES = Makefile test.sh