summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-31 23:12:15 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-31 23:12:15 (GMT)
commit2733f697b65bb475cede997cdc4d288118e5c828 (patch)
treea161b3a56b72eabad443917cb5402b38bb1e3130 /Makefile.am
parent926b953316fad230bd68e8dc01c805f6a148474e (diff)
downloadhdf5-2733f697b65bb475cede997cdc4d288118e5c828.zip
hdf5-2733f697b65bb475cede997cdc4d288118e5c828.tar.gz
hdf5-2733f697b65bb475cede997cdc4d288118e5c828.tar.bz2
[svn-r11330] Purpose:
Bug fix Description: Errors on sol may have been due to "make clean" being run both manually and by automake. Removed the manual run. Also cleaned c++/examples/ii_files directory created by some compilers (e.g., on modi4). Solution: This does mean that examples directories will not be cleaned by 'make clean'. Platforms tested: sol, mir, heping, modi4
Diffstat (limited to 'Makefile.am')
-rwxr-xr-xMakefile.am14
1 files changed, 0 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index e9b8658..ec07fc7 100755
--- a/Makefile.am
+++ b/Makefile.am
@@ -104,23 +104,9 @@ install-exec-local:
uninstall-local:
@cd perform && $(MAKE) $(AM_MAKEFLAGS) uninstall
-# Clean and mostlyclean need to recurse into examples and perform
-# directories unless they've already been distcleaned.
-clean-local:
- @@SETX@; for d in examples perform; do \
- if test -f $$d/Makefile; then \
- (cd $$d && $(MAKE) $(AM_MAKEFLAGS) clean) || exit 1; \
- fi; \
- done
-
# Some C++ compilers/linkers will create a directory named ii_files in
# the root directory, which should be cleaned.
mostlyclean-local:
- @@SETX@; for d in examples perform; do \
- if test -f $$d/Makefile; then \
- (cd $$d && $(MAKE) $(AM_MAKEFLAGS) mostlyclean) || exit 1; \
- fi; \
- done; \
if test -d ii_files; then \
$(RM) -rf ii_files; \
fi